Full Version: Google Play Services "Error: Incompatible with other..."
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
es from playstore it says

Google Play Services "Error: Incompatible with other application(s) using the same shared user ID"

I cant use gmaps and YouTube because it keeps asking me to install.

How can this be fixed?
Now that you have CWM installed, you can try installing gapps from SD. Please let us know if that fixes your problem.

[Only registered and activated users can see links Click here to register]
I tried installing latest 4.2.2 gapps but still does not fix the error. I noticed after flashing with cwm some gapps were not installed (titanium or settings>apps>all) but was present in my /system/app including gem.apk and googleframeworkservices.apk
1. Try the gapps I linked to

2. If that doesn't work, find a signed version of maps. Uninstall maps from Play (if it's installed at all) and install the signed version you downloaded from the net. Now update at Play.

3. If #2 doesn't work:

a.) connect your phone to PC and open command prompt
b.) adb shell chmod 666 /data/system/packages.xml
c.) adb pull /data/system/packages.xml
d.) open packages.xml and find the maps block
e.) comment out (or delete) shared user name code from maps block in packages.xml so it looks like this:

PHP Code:
<!--<shared-user name="com.navngo" userId="10000">
sigs count="1">
cert index="4" />
item name="android.permission.READ_PHONE_STATE" />
item name="android.permission.DISABLE_KEYGUARD" />
item name="android.permission.INTERNET" />
item name="android.permission.WRITE_EXTERNAL_STORAGE" />
item name="android.permission.ACCESS_FINE_LOCATION" />
item name="android.permission.ACCESS_LOCATION_EXTRA_COMMANDS" />
item name="android.permission.ACCESS_COARSE_LOCATION" />
item name="android.permission.READ_CONTACTS" />
item name="android.permission.WRITE_CONTACTS" />
item name="android.permission.ACCESS_NETWORK_STATE" />
item name="android.permission.WAKE_LOCK" />
item name="android.permission.MODIFY_AUDIO_SETTINGS" />

f. adb push packages.xml /data/system
g. adb shell rm /data/dalvik-cache/*
h. adb reboot
i. attempt the install again.

The reason this is happening is that whoever authored the firmware didn't do a clean job of it.
i already tried the gapps that you linked.
ill try the second one which i already tried but with the android userid
ill update this after i tried navngo Smiling

BTW, my main problem is the google play services it keeps asking me to install not the maps itself

i cant seem to find shared-user name="com.navngo" userId="10000
this is what i did
1. installed maps from gplay
2. reboot phone
3. pulled packages.xml
4. open in note++ and find (ctrl + F) com.navngo
i cant seem to find it in my packages, or maybe its not there in the first place..

ill attach my packages.xml
Find whatever block is causing giving you the error message and remove any shared IDs. Make a backup prior to doing any edits.
Can i do this using terminal emulator?
Update have fix this flashing the latest gapps. Reboot to cwm recovery wipe data/factory reset then flash gapps!
encountered same problem, because Chinese clean correctly MAUI rom ;)
Not sure service Google not required other lib:
add manually in system/app/GmsCore.apk (latest service Google from googleapps) and add lib files libgames_rtmp_jni.so and libAppDataSearch.so in system/lib (perhaps require real GooglePlayStore and MarketUpdate, I already replace it by original)
(2013-11-05, 14:46)Gizbeat Wrote: [Only registered and activated users can see links Click here to register]

Bro ...what would i do next ...after installing this file ..?? please describe.
Thank You !