www.chinaphonearena.com
[Question] Cubot x9 - problem with mocrophone - Printable Version

+- www.chinaphonearena.com (https://www.chinaphonearena.com/forum)
+-- Forum: Brand Specific (https://www.chinaphonearena.com/forum/forumdisplay.php?fid=79)
+--- Forum: Cubot® (https://www.chinaphonearena.com/forum/forumdisplay.php?fid=81)
+--- Thread: [Question] Cubot x9 - problem with mocrophone (/showthread.php?tid=8967)



Cubot x9 - problem with mocrophone - Michalf - 2015-02-04

Yesterday came to me new Cubot X9. I was waiting for it 50days :O
Unfortunately there is a problem with microphone. Its doesn`t working. I cant calling (becouse the caller can not hear me), recording whatever audio...
I thought that this technical fault, but when I plug in headphones (without mic) - audio recording starts working (only audio recording - when I call - mic doesnt work).
So microphone in my cubot is good, I think that this is problem with soft. I restored the factory settings, did update, loud microphone in engineering mode.. but its didn`t solved my problem.
Have You eny ideas what I can do to solve my problem?
Thanks!


RE: Cubot x9 - problem with mocrophone - glofish - 2015-04-08

I feel you. The problem with my microphone is I cannot record anything even with headphones plugged in. All i hear is a buzzing sound and people cannot hear me on calls.
Where is the microphone on a Cubot?

I rooted mine and this problem came after the root so it must be a software issue for me.

Hope we find someone who can help with this.


RE: Cubot x9 - problem with mocrophone - Cleopatra - 2015-04-08

Hi Michalf !

Some time ago I've posted a suggestion about audio configuration ... you could try it ... before modify the parameters remember to write the original audio configuration of your device into a txt :

INCREASE THE AUDIO WITH MOBILEUNCLE TOOLS:

The Max Volume is 160 , but a lot of people advise against to set the max volume to 160 because it could damage your phone. Set the max volume to 150 is more than enough.

THE AUDIO SETTINGS:

Open Mobile Uncle Tools and open engineering mode.
Under engineering mode, go to 'Hardware Testing' and go to ‘Audio’.
Go to ‘Normal Mode’ (front speaker)
Under ‘Type’ select 'Sip'.
Under ‘Level’ enter these values (Value is 0~255)

Level 0 < Value 160 Max vol 150 (press SET and OK)
Level 1 < Value 176 Max vol 150 (press SET and OK)
Level 2 < Value 192 Max vol 150 (press SET and OK)
Level 3 < Value 208 Max vol 150 (press SET and OK)
Level 4 < Value 224 Max vol 150 (press SET and OK)
Level 5 < Value 240 Max vol 150 (press SET and OK)
Level 6 < Value 255 Max vol 150 (press SET and OK)

Apply the same settings (above) to 'Sip' on ‘Headset Mode’ and 'Sip' on ‘Loudspeaker Mode’

'Loudspeaker Mode' is the back speaker.

Next, in ‘Normal Mode’ under ‘Type’ select ‘Mic’. Under ‘Level’ select ‘Level 0'.
Under ‘Value is 0~255' enter 255. For all levels, from level 0-6 set the value as 255 (there are 14 levels on my phone and I've set all levels to 255). This will ensure that your voice is audible to other person even when you turn down the speaker volume. Apply the same settings to ‘Headset Mode’ -> Mic and ‘Loudspeaker Mode’ -> Mic.
Next, in ‘Normal Mode’ under ‘Type’ select ‘Sph’. Under ‘Level’ select ‘Level 0'.
Enter these values under ‘Value is 0~160' for various levels.

Level 0 -> 90
Level 1 -> 100
Level 2 -> 110
Level 3 -> 120
Level 4 -> 130
Level 5 -> 140
Level 6 -> 150

Apply the same settings (above) to 'Sph2'
Apply the same settings (above) to ‘Headset Mode’ -> Sph, Sph2 and ‘Loudspeaker Mode’ -> Sph, Sph2
Next, in ‘Normal Mode’ under ‘Type’ select ‘Media’.
Enter these values under ‘Value is 0~255' for various levels.

Level 0 -> 32
Level 1 -> 48
Level 2 -> 64
Level 3 -> 80
Level 4 -> 96
Level 5 -> 112
Level 6 -> 128
Level 7 -> 144
Level 8 -> 160
Level 9 -> 176
Level 10 -> 192
Level 11 -> 208
Level 12 -> 224
Level 13 -> 240
Level 14 -> 255

Apply the same settings (above) to 'Headset Mode’ -> FMR, Media and Matv
Apply the same settings (above) to ‘Loudspeaker Mode’ -> FMR, Media and Matv

VERY IMPORTANT: remember to restart the phone after to apply all the settings.

I hope that my suggested audio settings and solutions help you :-)


RE: Cubot x9 - problem with mocrophone - glofish - 2015-04-16

Hey Cleopatra,
I tried your suggestion but it unfortunately hasnt worked. Any recording I make comes through as a steady buzzing sound.
I tried reflashing my stock rom but the problem persisted so I flashed back the CWM recovery I created.

Any other ideas?? Im stumped. Sad

(2015-04-08, 22:32)Cleopatra Wrote: Hi Michalf !

Some time ago I've posted a suggestion about audio configuration ... you could try it ... before modify the parameters remember to write the original audio configuration of your device into a txt :

INCREASE THE AUDIO WITH MOBILEUNCLE TOOLS:
.......



RE: Cubot x9 - problem with mocrophone - Cleopatra - 2015-04-16

Hi glofish !

You've written that this problem came after the root of your device.
Have you already tried a simple Factory Reset ?
Do you have a basic Recovery Mode on your device ?
Do you have a custom Recovery Mode ?
When you've tried to flash the stock rom ... before ... Did you follow the next procedure (into Recovery Mode) ? :
1) Wipe data.
2) Wipe cache.
3) Wipe dalvik cache.
4) Format System, Cache, Data.

:-)


RE: Cubot x9 - problem with mocrophone - glofish - 2015-04-16

Hey Cleopatra,
thanx for the quick reply.

I have not factory reset.

I am now using a CWM recovery and not the stock rom. I did not follow the wipe cache steps. Let me start with a simple factory reset and see. Then I will completely reinstall the recovery while going through the steps of
1) Wipe data.
2) Wipe cache.
3) Wipe dalvik cache.
4) Format System, Cache, Data.

And i shall be back to tell you if it works Smiling

(2015-04-16, 17:39)Cleopatra Wrote: Hi glofish !

You've written that this problem came after the root of your device.
Have you already tried a simple Factory Reset ?
Do you have a basic Recovery Mode on your device ?
Do you have a custom Recovery Mode ?
When you've tried to flash the stock rom ... before ... Did you follow the next procedure (into Recovery Mode) ? :
1) Wipe data.
2) Wipe cache.
3) Wipe dalvik cache.
4) Format System, Cache, Data.

:-)



RE: Cubot x9 - problem with mocrophone - Cleopatra - 2015-04-16

I'm able to reply quickly because gmail (on my phone) notify me every time that someone answer to me :-)
Maybe ... I think you meant "CWM rom" and not "CWM Recovery" ... I've tried to look for the CWM rom for your device on Needrom ... and I've found only the next :

[Only registered and activated users can see links Click here to register]

BUT it needs CWM Recovery or TWRP Recovery installed into the device.
I'm very curious to know where you've found the CWM rom :-)


RE: Cubot x9 - problem with mocrophone - glofish - 2015-04-16

And after doing all the above quite carefully and repeating the Mobile Uncle tools fix I am still getting the same static when I try record anything. Sad

(2015-04-16, 17:39)Cleopatra Wrote: Hi glofish !

You've written that this problem came after the root of your device.
Have you already tried a simple Factory Reset ?
Do you have a basic Recovery Mode on your device ?
Do you have a custom Recovery Mode ?
When you've tried to flash the stock rom ... before ... Did you follow the next procedure (into Recovery Mode) ? :
1) Wipe data.
2) Wipe cache.
3) Wipe dalvik cache.
4) Format System, Cache, Data.

:-)



RE: Cubot x9 - problem with mocrophone - Cleopatra - 2015-04-16

(2015-04-16, 19:16)glofish Wrote: [Only registered and activated users can see links Click here to register]

However, you could use the stock rom and follow step by step the next tutorial :

[Only registered and activated users can see links Click here to register]