Full Version: Oukitel K4000 root?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5

I've got an Oukitel K4000 phone, and it's a MT6735 device. There are tons and tons of information on older CPUs, but not on these new guys. Tools too, by the way. So I would like to have it rooted, but:
1. No auto rooting app seems to work.
2. MTK Droid Tools (and other similar applications) does not support this chip, so there's no way to get a scatter file (it might be done manually though, as MTK Droid Tools does show some part of the partitions table). This was also mentioned in this manual. However, I am not sure if that's the right way to go.
3. There are no roms/recoveries for this device yet, so if you help me, it could be the first =)

There are some positive prerequisites too:
1. I have unlocked the bootloader.
2. ADB and fastboot work just fine.
3. I am really pumped about this Big Grin
Yes, there is still no auto rooting tool that works with the newer 64-bit and Lollipop. Lots of websites claiming they do so they can get in Google searches, but it's a lie.

You will need a custom recovery and flash that and install SuperSU through SD.
(2015-11-23, 21:07)Bacon_Puffs Wrote: [ -> ]You will need a custom recovery and flash that and install SuperSU through SD.
Yeah, but there's no custom recovery for this phone so far. And no ROMs to create a custom recovery.
And if there is nothing that can be done manually, then the only way is to wait till developers release a ROM. Based on which, custom recovery can be created...
That's a sad sad prospect which I don't really like. Sleepy
So... any ideas on manual extraction of boot.img from the device? Wink

PS: This particular device is based on MT6735p and the system is 32-bit. Yeah, I know, weird.
Yes. Nothing can be done until Oukitel releases a stock ROM or an OTA with boot.img or recovery.img in it for the K4000.

That's strange regarding 32-bit. Did you run Antutu? See if it asks to DL the 64-bit when you try to run Antutu.
Antutu doesn't ask for 64-bit add-on, and it displays the device as 32-bit one. This is also confirmed by a few reviews on Youtube, as well as by actual owners of the device on another forum.
It doesn't affect performance as per my knowledge, so I don't really care. Still strange though.

Well, I do not believe in miracles, but here we go - I tried rooting via this instruction:
You have not permission to see this spoiler content !
using the exact file from the instruction, twice. First time with the original file, then had it renamed to "update.zip". Both times to no avail. Recovery reported invalid package and missing scatter.

Then a guy on another forum reported this file did root his device. So I tried for the third time, and guess what - it worked. Then I unrooted the device and tried it once more, having renamed the file to "update.zip". And once again, it worked. I don't even have words to describe what I feel Smiling

So, you have root an oukitel k4000?
I do not understand exactly how, I'm trying from a week ago, could you send me a procedure to root it please?

When I go to recovery it shows no command.robot down
Ok, so there are now two ways to root the device.

The first one is as follows. You take this file (if the link doesn't work, try [another forum one[/url]), and place it somewhere on your device. Then you run Wireless Update app on the device, choose "Local update" from the menu in the top right, select the file you've downloaded, and hit "Update now" and "OK". Your phone will restart and you will have root.

If that doesn't work (as it didn't for me for the first two times, as I described), try this manual by KlausMinator. I personally tried it after a factory reset, and it works.
Okkay, thanks a lot, a latest question, is it resetting the device?
For knowing if I have to save things

Thanks again Big Grin
Could you send a link for the Wireless Update app please?
I can't find it.. :/
Pages: 1 2 3 4 5